Gmail account keeps on disconnecting every time PC restarts

Same here but for me, all Gmail accounts are working ok, but one custom server account has the same problem people are talking about.

Mailspring Version: 1.9.1-30ef802f
Platform: win32
Account State: sync_error
Account Provider: imap
IMAP Server: imap.hostinger.es
SMTP Server: smtp.hostinger.es

36964 [2021-08-18 00:15:38.098] [background] [info] syncFolderChangesViaCondstore - INBOX.Sent: modseq 29 to 29, uidnext 264 to 264
36964 [2021-08-18 00:15:38.146] [background] [info] syncFolderChangesViaCondstore - INBOX.Drafts: modseq 3 to 3, uidnext 2 to 2
36964 [2021-08-18 00:15:38.193] [background] [info] syncFolderChangesViaCondstore - INBOX.Trash: modseq 4 to 4, uidnext 3 to 3
36964 [2021-08-18 00:15:38.240] [background] [info] syncFolderChangesViaCondstore - INBOX.Junk: modseq 1 to 1, uidnext 106 to 106
36964 [2021-08-18 00:15:38.287] [background] [info] syncFolderChangesViaCondstore - INBOX.Trash.Archives: modseq 1 to 1, uidnext 1 to 1
36964 [2021-08-18 00:15:38.334] [background] [info] syncFolderChangesViaCondstore - INBOX.Trash.Archives.2019: modseq 2 to 2, uidnext 2 to 2
36964 [2021-08-18 00:15:38.381] [background] [info] syncFolderChangesViaCondstore - INBOX.Mailspring: modseq 1 to 1, uidnext 1 to 1
36964 [2021-08-18 00:15:38.429] [background] [info] syncFolderChangesViaCondstore - INBOX.Mailspring.Snoozed: modseq 1 to 1, uidnext 1 to 1
36964 [2021-08-18 00:15:38.429] [background] [info] Sync loop deleting unlinked messages with phase 1.
36964 [2021-08-18 00:15:38.429] [background] [info] Sync loop complete.
36964 [2021-08-18 00:16:38.997] [foreground] [info] Idle exited with code 0
36964 [2021-08-18 00:16:39.041] [foreground] [info] syncFolderChangesViaCondstore - INBOX: modseq 225 to 225, uidnext 1777 to 1777
36964 [2021-08-18 00:16:39.045] [foreground] [info] Idling on folder INBOX
36964 [2021-08-18 00:17:38.443] [background] [info] Syncing folder list…
36964 [2021-08-18 00:17:38.585] [background] [info] syncFolderChangesViaCondstore - INBOX: modseq 225 to 225, uidnext 1777 to 1777
36964 [2021-08-18 00:17:38.636] [background] [info] syncFolderChangesViaCondstore - INBOX.Sent: modseq 29 to 29, uidnext 264 to 264
36964 [2021-08-18 00:17:38.684] [background] [info] syncFolderChangesViaCondstore - INBOX.Drafts: modseq 3 to 3, uidnext 2 to 2
36964 [2021-08-18 00:17:38.738] [background] [info] syncFolderChangesViaCondstore - INBOX.Trash: modseq 4 to 4, uidnext 3 to 3
36964 [2021-08-18 00:17:38.785] [background] [info] syncFolderChangesViaCondstore - INBOX.Junk: modseq 1 to 1, uidnext 106 to 106
36964 [2021-08-18 00:17:38.832] [background] [info] syncFolderChangesViaCondstore - INBOX.Trash.Archives: modseq 1 to 1, uidnext 1 to 1
36964 [2021-08-18 00:17:38.879] [background] [info] syncFolderChangesViaCondstore - INBOX.Trash.Archives.2019: modseq 2 to 2, uidnext 2 to 2
36964 [2021-08-18 00:17:38.926] [background] [info] syncFolderChangesViaCondstore - INBOX.Mailspring: modseq 1 to 1, uidnext 1 to 1
36964 [2021-08-18 00:17:38.973] [background] [info] syncFolderChangesViaCondstore - INBOX.Mailspring.Snoozed: modseq 1 to 1, uidnext 1 to 1
36964 [2021-08-18 00:17:38.973] [background] [info] Sync loop deleting unlinked messages with phase 2.
36964 [2021-08-18 00:17:38.973] [background] [info] Sync loop complete.

This issue is allmost overkilling for me, still no fix for this?

Same issue here using gmail.

1 Like

Same here. 4 accounts : 2 IMAP with no problem.
1 gmail > need to reconnect each time PC restart
1 hotmail > need to reconnect each time PC restart

I have this problem too… with 3 gmail/gsuite accounts. Everytime my computer restarts I have to reconnect all 3 accounts.

Same problem here, has anyone been able to find a fix?

Confirming the same issue, only occurring in Windows (not in my Linux installation), and affecting both google and fastmail (imap) accounts.

Happening once again for me too…

I FOUND A FIX

Solution:

  1. I completely uninstalled my mailspring from my computer, all the data and cache
  2. I permanently deleted my mailspring ID
  3. I installed mailspring 1.7.8 from Mailspring 1.7.8 Download

It has been working for me now for over a week without any problems with all my accounts

1 Like

Same issue for me as well. Hotmail and Gmail.

What i don’t understand is that this issue is already surfacing since version 1.9.1 and 1.9.2, the latest version.
Why does it take so long for a fix? :frowning:

I tried the above mentioned solution from @adawg as well, although with version 1.9.0. since this was the latest version before the syncing issues surfaced(if i’m correct…), but after a restart it got updated to the latest version, so that did not help either.

Maybe a good idea is to implement an option to disable automatic updates? :thinking:

I’m still having this issue. Will it ever be fixed? :frowning_face:

Having this very issue on 2/6 of my active Gmail accounts. The error started happening after changing the passowrd of the two accounts. It’s fixed by re-linking the accounts to Mailspring through the browser, but then happens again when the PC is restarted.

2 Likes

Well, although i liked mailspring, this syncing issue drives me crazy. Am gonna forget and move on for now.

And what is worse…it’s there already for quite some time :frowning:
Even the previous version had this issue and when the latest version got pushed, the syncing issue was still there???
That part i really don’t get! I would expect if a newer version got pushed that at least that part was solved, but nope.

This issue only seems to happen on my work PC. On my home PC and laptop this doesn’t happen. I’ve tried re-installing but still doesn’t work on my work pc. how is this possible?

Anyone found a solution for this error? how to reach out to Mailspring team? Even for Mailspring Pro… This issue is occuring… Love mailspring this issue is seriously irritating…

1 Like

I really like Mailspring but I experienced this problem as well. This unfortunately makes Mailspring unusable for the moment. If anyone is picking this issue up to fix it and needs more information to reproduce, do not hesitate to post here.

Until this is fixed I have to use another mail client.

Do you guys have any solution for this sync error?

image

image

I have subscribed to mailspring but i could not find any solution for this error. It is really frustrating. I would really appreciate if you could help on this one? i could not able to reach the support team as well. kindly point me to the right direction if you can…

Please help.

TLDR: If you are a Windows user, try this:

  1. Go to Credential Manager > Windows Credentials, and remove Mailspring Keys.
  2. Reconnect your account(s).

I made a custom Mailspring-Sync build to debug token refresh logic, and noticed that the refresh token passed to Mailspring-Sync is not the most recent one. It seems to me that when a user reconnects an account, the credentials are not properly saved into Credential Vault on Windows. On a reboot Mailspring passes an old (and expired) refresh token to Mailspring-Sync, which causes it to fail to refresh the access token.

After I clear the credentials from Credential Vault, the problem seems to be fixed. I have no idea how to reproduce this issue (i.e. why credentials are not updated on reconnect), so I can’t really propose a fix. If someone can let me know under what condition the credential stored in Credential Vault become out of sync, I might be able to take a closer look.

2 Likes

Thank you. Your solution currently work for me. It solved the Sync problem of Mailspring with my Yahoo Mail and Gmail connection.

The same thing happens to me too.

2 other accounts work OK but this one does not.

17500 [2022-06-18 21:44:34.555] [main] [info] Identity created at 1514455141 - using ID Schema 0
17500 [2022-06-18 21:44:34.556] [main] [info] ------------- Starting Sync (<EMAIL>@gmail.com) ---------------
17500 [2022-06-18 21:44:34.558] [metadata] [info] Metadata delta stream starting...
17500 [2022-06-18 21:44:38.567] [background] [info] Fetching XOAuth2 access token (gmail) for bcfa1827
17500 [2022-06-18 21:44:39.216] [background] [critical] 
***
*** Mailspring Sync 
*** An exception occurred during program execution: 
*** {"debuginfo":"https://www.googleapis.com/oauth2/v4/token RETURNED {\n  \"error\": \"invalid_grant\",\n  \"error_description\": \"Token has been expired or revoked.\"\n}","key":"Invalid Response Code: 400","retryable":false,"what":"Unknown exception"}
***

Been almost 2 Years - Still frustrated by this sync problem on my mac!

Any suggestions for a closer mail client alternative to mail spring?