Gmail Sync Error (unsupported OAuth)

Is this for a Gmail or a Google Workspace account?

For a regular Gmail account.

Check out this post for links to related posts:

It is still persistent with the new app update

  • Version : 1.10.5-1ce06f18
  • I completly reinstalled mailspring
  • Tryed to add regular gmail account
  • Gmail interface aknowledge me that the gmail account has already access permissions for mailspring
  • I’m getting success confirmation on web portal but the application returns a mailsync error


I have the same issue today. Any way to fix this?

1 Like


I dont know if they just fixed it…but what I did differently was checking all the options…then Gmail works fine in Mailspring app.

Hi. It’s still not fixed for me. All six access options were already checked, and I just tested it with a fresh installation on a different machine too.

  1. Can you confirm if you’re on the app version “1.10.5-1ce06f18”?
  2. Are you on a Windows machine?
  3. When did you first encounter this error?

I’ve also noticed that what you’ve reported is an “authentication error” which is not the same as on the original post.

Same issue today FYI

1 Like

Same here, Mailspring stopped working for my 4 gmail accounts 2 or 3 weeks ago. Is anyone working on this?

1 Like

The issue doesn’t affect desktop apps [1], it may be that Application Type on the Google Cloud " OAuth client ID" isn’t set to Desktop Application - which is causing the warning. Also, the app is old enough to not be affected by this change

However, all this does not explain the sync issues :man_shrugging:

1 Like

Hola, me descargue hace 2 dias, me funciona con 2 cuentas corporativas que tengo que las añado como (IMAP/SMTP) y las de Gmail cuando deshabilito mi antivirus (AVAST-PREMIUM). Con el windows defender que sale por defecto en W10, me sale la notificación de permitir en Firewall, y me funciona correctamente., otra opción que también me funciona es en: Mailspring (IMAP/SMTP)- configurar cuenta - marcar: [ permitir SSL inseguro ],hay que crear (contraseña de aplicación en Gmail), pero no tengo muy claro que sea conveniente dejarlo así. Ahora me estoy “peleando” con el firewall del AVAST, pero no consigo nada…alguien me puede ayudar ???. Lastima de este problema, porque la aplicación me gusta y por el precio vale la pena adquirir la de pago. Gracias y saludos.

1 Like

Hola, así es como me sincroniza, pero creo que se pierde la seguridad…

Según he leído es tema de actualizar los certificados…
Supongo que en próximas versiones se solucionara, de momento a esperar una solución, gracias.

Thanks! I use Avast antivirus too and I was able to sync my mail by temporarily disabling Avast shields control.

Trying to add the same account using IMAP/SMTP didn’t work for me. I don’t have 2-factor authentication turned on, so application password is not needed. And I’m sure I entered the correct username and password.

Hope a permanent fix is found soon!

Hola, ya no uso AVAST, ahora tengo ESET Internet Security, y MailSpring me funciona y sincroniza con Gmail sin ningún problema.
No he tenido ni que activar ni desactivar ningún escudo, opción , etc…
Y así me voy a quedar, ESET es el que usan los ordenadores de donde trabajo y no hemos tenido ningún problema…

The issue is now resolved for me and Mailspring works with Avast.

I am currently facing this issue, it happened around 2 days ago. I even tried using the IMAP method but it keeps saying “Authenciation Error- Check your Username and Password” even tho it’s the correct password

This was fixed in 1.10.5, is this the version you’re using?


Hello, yes this is the version I am using, I have tried uninstalling and re-installing but still no luck

I also tried changing my default browser, from brave to firefox and back to chrome all logged in with my google account, I used Iobit to uninstall mailspring each time and disabled my adguard also. The website always said “Your Mailspring is all set” but it keeps returning “Connection Error - Unable to connect to the server / port you provided. (SMTP)”

I have been experiencing this same issue for about 20 days now. Is there a current fix?

I am still experiencing this issue it keeps persisting after reinstalling clearing caches and reauthenticating. What can I do to resolve this issue.