Mailspring Down: Can't access any of my email accounts, Getting Security Warnings, Website Down. What [tf] is going on?


I am getting the error “Several of your accounts are having issues.” When I click on “Check Again” nothing happens. I am not receiving any new mail. When I click on Manage, I am brought to my Accounts page in Preferences that lists all my accounts with a red warning sign and message stating:

Mailspring encountered errors syncing this account. Crash reports have been sent to the Mailspring team and we’ll work to fix these errors in the next release.

It gives me the option to Reconnect or view Error Details (the latter does nothing). Clicking Reconnect asks me to sign in to my account again. When I do this, I’m taken to my gmail sign in, input my information and re-authenticate Mailspring’s access to my account. After authenticating I am taken to but am getting a warning:

Your connection is not private. Attackers might be trying to steal your information from (for example, passwords, messages, or credit cards)

I get the same error when I try to go to

Returning to the app after re-authentication, at first the red warning label on my account goes away, but then it immediately returns.

I thought at first that maybe I needed to update my application (I am on Mac using version 1.10.3-a476c230) but when I check for updates I get the following error:

There was an error checking for updates. The certificate for this server is invalid. You might be connecting to a server that is pretending to be “” which could put your confidential information at risk. Would you like to connect to the server anyway?
My only option is “OK” which once again does nothing

To Reproduce…

Steps to reproduce the behavior:

  1. I don’t know, just open the app! I have used this fine for the past few weeks, and excitedly so! The client is great! When I opened it today, this is what happened.
  2. I tried restarting the app. This had no affect.

Expected Behavior

The app to work and not give a bunch of frightening security warnings! The website for this app to not suddenly be down?


CleanShot 2022-06-28 at 10.31.27

I have more screenshots but can’t embed them, great.


  • OS and Version: macOS Big Sur 11.6.6
    • Installation Method: App
  • Mailspring Version: 1.10.3-a476c230

Additional Context

This is extremely concerning. I have no idea what’s going on, but I need an explanation. If my data is at risk or has been compromised I want to know. What’s more frustrating is not being able to find any dedicated support email address to report this. And it’s concerning to not see any activity in this forum.

I can confirm that behaviour. Mailspring is down because of an outdated wildcard TLS certificate for * issued by Amazon. It expired today and must be renewed. Otherwise the Mailspring client rejects all connections (e.g. to The effect can be seen by just visiting the homepage:

Yes, I’m going to try to remove my post since the issue has been spotted by other users (like yourself) who clearly understand this better than I do.

Edit: Can’t seem to figure out how to delete the post, so I’ll just link to the correct thread: - Expired SSL cert