Mailspring Generates an Error Message Sending Mail With VPN is Invoked

I am a Mailspring Pro customer. I have 4 accounts setup in Mailspring and it’s working fine with all 4 accounts sending and receiving mail so far except when running a VPN. I use Wireguard VPN.

The version of Mailspring I’m running is version 1.9.1-30ef802f. Mailspring is installed on Feren OS Linux July 2021 build with kernel ver. 5.4.0-81-generic.

I am not running any HTTP proxy server in the browser and not running SOCKS5 proxy with Wireguard. When I invoke my Wireguard VPN, I’m able to receive messages just fine, but cannot send messages out. I get an error message which reads: “Error - Sorry. Mailspring was unable to deliver this message. Connection Error - Unable to connect to the server/port you provided.” I have to click Okay to close this window. This error is 100% reproducible. When I turn off the VPN, the message will then be sent out. I don’t understand why this is happening as I’ve never had an issue with other mail clients like Thunderbird Mail delivering mail with a VPN turned on.

Please let me know what can be done to resolve this issue. I want to continue using the Pro version of Mailspring, but can’t live with the VPN problem I discovered.

Thank you.

Dan Calloway

1 Like

This is not support. It’s been 6 days since I posted this request for assistance with my issue and no one–AND I MEAN, NO ONE–has offered to even acknowledge that they are working to find a resolution to my problem. As I mentioned, I’m a paying customer of Mailspring and would think that I would get better attention than this.

If someone doesn’t assist to at least attempt to resolve my technical issue with Mailspring soon, I may have to reevaluate its continued use as a paying customer. Did I post this in the wrong place? Can someone at least tell me that and offer to direct me in the right area? Thank you.

Dan Calloway

Mailspring is largely abandoned frustratingly. Many of it’s users have left it and gone back to alternatives.

It’s been riddled with countless bugs for many months now with zero acknowledgement or official support.

See this thread (and there are loads of other threads with complaints from users).

Zigojacko, thank you for replying to my post. You’re the only one who has so far. It’s not like I can’t live with Mailspring if this issue isn’t resolved, but its the fact that I pay to use it and can’t get help from anyone at Mailspring–not even to acknowledge that they received my post. That’s unconscionable.

No problem and yep, that’s pretty much exactly what I also stated in my post that I linked to above - and that was from June. So several months after that, there has been zero acknowledgement of any bugs or issues which continue to increase etc. It’s simply not usable for me in a business environment and I expect more from software that I have paid for as well.