Password Management Error

You can also force it with snap run --shell mailspring -c "mailspring --no-sandbox --password-store=gnome-libsecret"

1 Like

I am on Arch Linux and unfortunately, after trying everything from above, i am still getting the password storage error for both the snap and the arch package.

Even though …

mailspring --password-store=“gnome-libsecret” &

… runs the application, the changes to the password storage are not permanent. And changing the mailspring.desktop file did not solve anything, at least for me.

For those who would like to downgrade the package on Arch or derivatives to the working version 1.11 , this command helped me:

pacman -U file:///var/cache/pacman/pkg/mailspring-1.11.0-1-x86_64.pkg.tar.zst

This requires adding

IgnorePkg = mailspring

to the etc/pacman.conf

1 Like

I have the same issue as @rainer2208. Details:

Mailspring 1.13.1 installed via Arch Linux AUR, regardless of whether it is run as mailspring or mailspring --password-store=“gnome-libsecret”, has the same result. It starts up with a popup saying that the keyring could not be read. Upon loading the application, none of my accounts are available and I get the same message again if I try to log in to my Mailspring account. Logs:

[91035:1130/181116.685555:ERROR:object_proxy.cc(623)] Failed to call method: org.freedesktop.DBus.Properties.Get: object_path= /org/freedesktop/portal/desktop: org.freedesktop.DBus.Error.InvalidArgs: No such interface “org.freedesktop.portal.FileChooser”
[91035:1130/181116.685595:ERROR:select_file_dialog_linux_portal.cc(274)] Failed to read portal version property
Running database migrations
App load time: 208ms

{"error":null}
libva error: vaGetDriverNames() failed with unknown libva error
Manual update check (updates.getmailspring.com/check/linux/x64/1.13.1-59cb1b1d/34720345-3659-40ba-8f3a-b0e5d86af309/stable) returned 204

Downgrading to 1.11.0-1 has the application working again for me. The errors about FileChooser are still present but doesn’t really affect anything.

  • Manjaro 23.1.0
  • i3 wm 4.23-1
  • gnome-keyring 1:42.1-3
  • xdg-desktop-portal 1.18.1-1
  • xdg-desktop-portal-gtk 1.15.1-1

XDG desktop is properly configured for GTK to be be fallback including specifically for i3 wm, not sure why the FileChooser errors are present.

For anyone using mailspring with flatpak, the method is very similar you just need to add --password-store=“gnome-libsecret” to your desktop file. To find where your desktop file is, you might want to do something like:

find ~/.local/share/applications/ /usr/share/applications/ /var/lib/flatpak/exports/share/applications/ ~/.local/share/flatpak/exports/share/applications/ -name '*mailspring*.desktop'

and then replace:

Exec=/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=start-mailspring --file-forwarding com.getmailspring.Mailspring @@u %U @@

To:

Exec=/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=start-mailspring --file-forwarding com.getmailspring.Mailspring --password-store="gnome-libsecret" @@u %U @@

I had to reconnect all my accounts and my mailspring id but after that it work even after restart.

I take this back. After restart I had the same issue. “Your mailspring Id could not be loaded from your keychain…” This fix is not working.

1 Like

Here to confirm what @skylite21 mentioned, the supposed fix does not work.
Adding the --password-store="gnome-libsecret" parameter doesn’t do anything for me.

I made sure to also change the Flatpak desktop files under:

USERNAME@pop-os:~$ locate com.getmailspring.Mailspring | grep .desktop

Which gave me the following results:

  • /home/USERNAME/.local/share/flatpak/app/com.getmailspring.Mailspring/x86_64/stable/e4e099bd840a9cacc61cc0bf49ee6df1035e78b091e3941274091ccee06cdd0a/export/share/applications/com.getmailspring.Mailspring.desktop

  • /home/USERNAME/.local/share/flatpak/app/com.getmailspring.Mailspring/x86_64/stable/e4e099bd840a9cacc61cc0bf49ee6df1035e78b091e3941274091ccee06cdd0a/files/share/applications/com.getmailspring.Mailspring.desktop

  • /home/USERNAME/.local/share/flatpak/exports/share/applications/com.getmailspring.Mailspring.desktop

But sadly, it does not seem to fix it. I checked under the “Passwords and Keys” app to make sure that Mailspring actually writes an entry into the keystore, and it does.
All other apps can read and write to/from the keystore so this is an issue specific to Mailspring.

To fix this, I did the following:

  1. list all Flatpak versions of the Mailspring app available:
flatpak remote-info --log flathub com.getmailspring.Mailspring
  1. Pick the version you want to downgrade to, in my case the following commit (v. 1.10.7):
flatpak update --commit=1efcb0434736d5248718166ed235b551bc6b513d14163b61950abf8213a5a894 com.getmailspring.Mailspring
  1. Clean up the old Flatpak files (make sure Mailspring is closed!)
cd ~/.var/app/
rm -rf com.getmailspring.Mailspring/
  1. Start Mailspring and the wizard should now come up. Connect your accounts.

Warning:
I found that connecting my Gmail accounts takes ages after I login. You have to wait at least 5 minutes after authorizing Mailspring before it actually adds your accounts. Just leave your browser window open until the Mailspring window closes and your account is added.
Also, I found that I had to add my Gmail accounts twice. After adding them, I immediately got an error that it couldn’t connect. If I then reconnect and authorize again, the accounts work.
Maybe this is something specific to version 1.10.7.

EDIT:
Forgot to add, if you want to prevent Flatpak from updating the package, you can do so by doing this:

  1. List all the Flatpak apps
flatpak list
  1. Copy the name of the Flatpak ID, in this case
com.getmailspring.Mailspring
  1. If you’re on PopOS like me, Flatpak is set up in user mode. Masking the package needs to be done like this:
flatpak mask --user com.getmailspring.Mailspring

Other distro’s sometimes don’t have to use --user, but instead just the App ID.

  1. You can list all masked packages with:
(sudo) flatpak mask

Depending on your distro, you might have to use sudo and --user to successfully mask the Flatpak package. I found in the past that the Pop!_Shop, which is a GUI frontend for the APT and Flatpak package managers, would sometimes continue to try and update masked packages. That is why I mention using --user and sudo here to prevent more unnecessary head scratching and troubleshooting.

  1. The final step, test if flatpak wants to update the package by running:
flatpak update

Mailspring, alongside all other masked apps, should no longer show up in this list and are now excluded from being updated.

I just realized that my problem was caused by the fact that after restart I run mailspring from an autostart script of mine which did not use the --password-store=“gnome-libsecret” flag. When I corrected that autostart script then everything worked again.

1 Like

ugh still struggling with this after many days. I can get it running correctly from the command prompt using --password-store=“gnome-libsecret” but changing .desktop files just does not seem to work. I’ve tried AUR and Flatpak versions, with the latter tried changing both

/var/lib/flatpak/exports/share/applications/com.getmailspring.Mailspring.desktop

and

/var/lib/flatpak/app/com.getmailspring.Mailspring/current/active/export/share/applications/com.getmailspring.Mailspring.desktop

but nothing seems to change anything, it still flashes the error on launch.

@dafeder If you use a startup script like me for the flatpak version, to make Mailspring load on login in a minimized fashion, you can do this:

/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=start-mailspring --file-forwarding com.getmailspring.Mailspring --background @@u %U @@

You can add --password-store=“gnome-libsecret” BEFORE the … @@u … to this to make it so that Mailspring starts up correctly. If I am not mistaken, on the Github issue page, there is an example how to do this. If I come across it, I will update my comment. If you can’t get it to work at all, you can try to just downgrade the Flatpak package. I’ve written a comment how to do so. Downgrading solved the issue for me.

I did have the @@u stuff at the end. I’ve gone back to AUR for now, tried downgrading to 1.12 but still the same issues! Very confused.

I now have (with the AUR package) both my /usr/share/applications/Mailspring.desktop file and a copy in ~/.local/share/applications with the last line set to

Exec=mailspring --password-store="gnome-libsecret" %U

Still get password storage error if I start mailspring from the launcher. Only thing that works continues to be running mailspring --password-store="gnome-libsecret" from prompt and keeping the terminal open.

OK this is what the :man_facepalming: emoji is for. I didn’t realize there were two sections of the .desktop file, I was editing the Exec for [Desktop Action NewMessage] not [Desktop Entry]. Now working fine

2 Likes

The way I solve this issue.

  1. Delete any previous auto-start entry of Mailspring from System Settings and/or from ~/.config/autostart directory.
  2. I do not prefer flatpak or snap. I use the .deb file, downloaded from official website.
  3. After install, do not run/launch the app.
  4. Locate Mailspring.desktop file in /usr/share/applications/ directory and open it in text editor.
  5. In [Desktop Entry] section, not [Desktop Action NewMessage],
    replace this line
    Exec=mailspring %U
    with
    Exec=mailspring --password-store="gnome-libsecret" %U
  6. Save the file & now run mailspring.

Everything should work as expected.

2 Likes

This works for me now!

I copied Mailspring-folder in username/.config into a backup folder and installed a new Linux distribution. After copying the folder back into the new distribution, I got this error message when starting Mailspring for the first time. Now I’m able to use Mailspring again. Thanks! :+1:

1 Like

I think it is broken with the KDE 6 update and shows this error. Not sure who’s fault it is. I’ve seen other people mention this so it shouldn’t be a me problem…

I have also recieved this issue upon updating to KDE 6, the “libsecret” fix won’t give me temporary repireve as well…

Same issue here after upgrading to KDE6 on Arch Linux, also took the opportunity to finally move from X11 to Wayland, though that should be N/A? Any bandaids? Totally locked out :frowning: @Phylu

Moving into it’s own issue thread saw was created the other day, anyone with this issue should shimmy over here and vote:

@1nikolas @Quanthum

That sounds like there was a switch from wallet5 to kwallet6 in the background. So your Mailspring is not able to access it’s encryption key for the passwords anymore. See: safeStorage | Electron

I’d assume that removing all mail accounts, logging out of your mailspring id and then logging in to everything again should work.

Another reason could be that the electron version shipped with Mailspring does not yet contain the bindings for kwallet6. In that case you could try to Ensure that kwallet5 is installed an force it’s usage with the corresponding flag in the desktop file.

I am currently traveling, but will try to figure out a solution when I am back.

1 Like

I finally found a solution with KDE 6 that solved the problem for me.

  1. In the Application Launcher, search for Mailspring.
  2. Right click on it and select “Edit Application…”
  3. Navigate to the “Application” tab.
  4. Update the “Arguments” field to read '--password-store=gnome-libsecret %U'
  5. Click “OK” at the bottom and close the menu.

Hope this helps anyone else encountering this issue in KDE 6.

2 Likes