V1.10 on Windows: better_sqlite3.node is not a valid Win32 application

Is anybody else getting this error messagebox? I’m getting it in an infinite loop when I try to start the app.

We encountered a problem with your local email database. We will now attempt to rebuild it.

Error:
\\?\C:\Users\Username\AppData\Local\Mailspring\app-1.10.0\resources\app....\better_sqlite3.node is not a valid Win32 application.

Was Mailspring cross compiled? In the past better-sqlite3 has had some cross compilation bugs (which are admittedly currently closed).

Of note, file tells me: \better_sqlite3.node: PE32+ executable (DLL) (GUI) x86-64, for MS Windows. So, not a Win32 application, but a Win32 (Win64) DLL.

4 Likes

I’m getting the same error. It never was a thing back when I used mailspring 5 months ago…

2 Likes

Same here! Mailspring doesn’t start and instead shows the error. Clicking okay just throws the error again. This wasn’t an issue in previous versions.

1 Like

Tried to install on Windows 10, same result. I had to reinstall the previous version.

1 Like

The same problem. Where can I find previous version of Mailspring?

any solutions?
ending the process tree and restart it does not seem to fix it…

Same issue here, Clicked on update this morning and got a similar error message. The package/node that the error message refers to does not exist.

Killing task does not help. Had to uninstall and reinstall. Probably going to lose all of my customisation. Really poor update management.

EDIT: can’t even reinstall as I’m getting exactly the same error message!
Time to find a better email client.

Hi there…
I solved it by terminating the process tree and restoring the launch icon property to the previous version

I know it’s not a great solution… but it works, until they fix it

2 Likes

The same with me. Fortunately I was able to restore the installer of the previous version and after installing it works again.

Is there a way to download a previous installer? I’m stuck in a loop of doom where I can’t progress any further than the error panel. TIA

Same problem. I had a support call from someone in a state of panic since they waited on the urgent acceptance of quotes and without that acceptance their installation teams cannot go out. Since there is no old version of Mailspring or old installer available on that machine the better alternative is to say bye-bye to Mailspring for good.

Found the old installer in another thread:

1 Like

Yep, completely broken here as well and goes into a horrible error loop that is difficult to kill even with Ctrl Alt Del.

Thanks for the link to the previous version - reverted.

As a workaround for this annoying issue, you can terminate the process, then delete the 1.10. files and folders (should be in C:\Users…\AppData\Local\Mailspring). Take care, that the older version (for me it is “app-1.9.2” stays there. Then Mailspring will start the normal way and asks you, if you want to update, which you should decline.

3 Likes

Same here, Windows 11. Had to kill the process tree to end a failure loop, delete the 1.10 directory and install 1.9.1. Pretty disappointing. Did they test on Windows? :smiley:

Same here, Windows 11, working fine for at least one month, suddenly get this failure loop, will not get out of it without CTRL+ALT+DEL. Only way was to install 1.9.1. Tried updating that install to 1.10 afterwards, got the failure loop back.

Looking forward to not having to deal with permafail loops.

Same error here:

system config:
AMD Ryzen 9 5900HS with Radeon Graphics 3.30 GHz

Edition Windows 10 Home
Version 21H2
Installed on ‎11/‎11/‎2021
OS build 19044.1526
Experience Windows Feature Experience Pack 120.2212.4170.0

resolved by deleting the update folder suggested by @tmx976

didn’t need to reset the path of the application as they had.

Feels like a bad update got pushed or something snuck past QA team

It definitely appears to be a bad update that wasn’t tested properly. I was having the same issue this morning after the update to v1.10. I was able to follow guidance from @bowihowi4u and manually deleted the v1.10 files & folder (in C:\Users…\AppData\Local\Mailspring) and changed the Mailspring launcher icon to point back to the v1.9.2 folder.

Everything seems to be back to normal now - definitely going to ignore the prompt to install v1.10 update until I see confirmation this issue has been addressed.

This isn’t the first time this has happened…at least to me. This is happening again. I reinstalled the previous version and made sure to get rid of the 1.10 stuff. As soon as I close Mailspring and open it up again, I get this loop.

At this point, I am ready to ditch Mailspring. As much as I love it, I honestly cannot take time out of my day to fix this error every time it comes up.

1 Like

Me too
After reinstalling the application, I lost all of my settings. but I still get the same error.